Bloc-notes

Freebox Player, OpenWrt, WDS et VLAN

Rédigé par Nicolas Sulek 39 commentaires
Ayant une Freebox Crystal, il est impossible d'utiliser le Wi-Fi entre la Freebox et le Freebox Player, ce dernier n'ayant plus de module Wi-Fi...

Ne pouvant utiliser le CPL pour cause de circuits électriques séparés, j'ai utilisé mes deux routeurs Wi-Fi TP-Link Archer C7 sous OpenWRT pour faire fonctionner le Freebox Player. réseau Freebox-OpenWrt

Configuration du routeur Wi-Fi OpenWRT 1

La Freebox utilise le VLAN 100 pour communiquer avec le Freebox Player. A noter qu'il n'est pas utile de configurer la Freebox en mode routeur, on peut la laisser dans sa configuration normale.

Mise en place du VLAN 100

On va donc créer le VLAN 100 et l'attacher aux bons ports réseaux.

Dans mon cas, la Freebox est connectée sur le port WAN du routeur Wi-Fi OpenWRT 1. Si on suit la documentation du wiki d'OpenWRT, ça correspond aux ports 1 (WAN) et 6 (eth0) du switch du TP-Link Archer C7.
De plus, il faut également utiliser eth1 correspondant aux ports internes du switch et créer un pont entre eth0 et eth1 pour assurer une communication entre le port externe (WAN) et les ports internes (LAN).

Dans la configuration d'OpenWRT, ça se traduit par l'ajout dans /etc/config/network de :
config switch_vlan
	option device 'switch0'
	option vlan '100'
	option vid '100'
	option ports '0t 1t 6t'

config 'interface' 'fbx'
	option 'proto' 'none'
	option 'send_rs' '0'
	option 'stp' '1'
	option 'type' 'bridge'
	option 'ifname' 'eth0.100 eth1.100'

Configuration du Wi-FI

Il va falloir transporter ce VLAN 100 par Wi-FI, or, les VLAN sont spécifiques à Ethernet, ils ne peuvent avoir comme support le Wi-FI. Il faut donc créer un nouveau SSID qui sera rattaché à l'interface fbx. Le routeur Wi-FI OpenWRT 1 aura également un rôle de serveur WDS.

Dans /etc/config/wireless, il faut rajouter :
config wifi-iface
	option device 'radio0'
        option mode 'ap'
        option ssid 'fbx'
	option wds '1'
	option hidden '1'
        option encryption 'psk2+ccmp'
        option key 'password'
        option network 'fbx' 

Configuration du routeur Wi-Fi OpenWRT 2

Mise en place du VLAN 100

Comme pour la Freebox, le Freebox Player est branché sur le port WAN. Il faut donc déclarer le VLAN 100 pour les ports 1 et 6 correspondant au port WAN et à eth0, et le port 0 correspondant à eth1 pour avoir un lien entre les ports internes et le port externe, sous la forme d'un pont.

Dans /etc/config/network, il faut rajouter :
config switch_vlan
	option device 'switch0'
	option vlan '100'
	option vid '100'
	option ports '0t 1t 6t'

config 'interface' 'fbx'
	option 'proto' 'none'
	option 'send_rs' '0'
	option 'stp' '1'
	option 'type' 'bridge'
	option 'ifname' 'eth0.100 eth1.100'

Configuration du Wi-FI

Pour que le VLAN 100 soit transmis par Wi-FI, il faut déclarer un nouveau SSID et le routeur Wi-FI OpenWRT sera client WDS.
Dans /etc/config/wireless :
config wifi-iface                       
        option device 'radio0'          
        option mode 'sta'                
	option wds '1'
        option ssid 'fbx'           
        option encryption 'psk2+ccmp'
        option key 'password'
        option network 'fbx'
Il ne reste plus qu'à allumer le Freebox Player et constater qu'il passe bien l'étape Réseau.

39 commentaires

#1  - tomazinio a dit :

Bonjour,

Trés intéressant votre article. Je vois que vous maitrisez openwrt. Alors, j'en profite pour vous poser une question que je n'arrive pas à résoudre depuis un certain temps sur l'utilisation d'openwrt. J’aimerai savoir s’il est possible de connecter un mini-routeur sous openwrt (dernière version 15.05.1) à un réseau wifi (dans une résidence universitaire, je n’ai pas d’accès par rj45) dont on a l’identifiant et le mot de passe et créer derrière un réseau wifi sécurisé pour accéder à l’internet. Si oui, comment dans les grandes liqnes ?

L’intérêt serait de connecter sur le routeur une imprimante réseau qui n’a qu’un cable éthernet (pas de wifi), un ordinateur portable et un téléphone en wifi par un tunnel openvpn pour sécuriser la connexion des 2 appareils.

Vous remerciant de votre aide,

Cordialement

#2  - Nicolas Sulek a dit :

Bonjour,

je ne suis pas expert openwrt :-D mais oui, ce que vous voulez faire est possible.

En résumé, Il faut configurer openwrt comme client du réseau Wifi universitaire, puis créer un 2ème réseau Wifi personnel et configurer un pont entre les deux. Ca se fait normalement assez facilement avec l'interface Web.

Je vais voir pour vous l'expliquer en éditant directement dans les fichiers de configuration dès que possible.

#3  - tomazinio a dit :

Bonjour,

C'est vraiment sympa de votre part.

En fait, je n'arrive pas à paramétrer les 2 réseaux wifi. On me dit qu'il faut 2 cartes wifi. Je n'en ai qu'une sur mon routeur NEXX WT3020. Il faudrait en créer une virtuelle ?

le forum et le wiki d'openwrt sont en anglais et je ne pratique pas trop l'anglais. Je ne comprend donc pas trop quoi chercher et surtout quoi faire.

Vous remerciant de votre aide,
Cordialement.

#4  - Nicolas Sulek a dit :

Ah mince, je n'avais pas vu que vous ne compreniez pas trop l'anglais :-/

Non pas besoin d'en créer une virtuelle. Il faut aller dans Network/Wireless, puis au niveau de votre carte Wifi, faire un Add (à côté de Scan) et rajouter un 1er réseau Wifi correspondant au réseau universitaire, en mettant comme mode Client et comme réseau WAN.
Ensuite, il faut refaire un autre Add et rajouter un 2ème réseau Wifi qui sera votre réseau interne, en mettant comme mode Acces point et comme réseau LAN.
A noter que certaines cartes ne savent pas gérer plusieurs SSID en même temps :-/

Une fois ces réseaux créés, il faut aller dans Network/Interfaces.
Editez WAN et mettez comme protocole DHCP client, vu que les adresses IP doivent être attribuées dynamiquement.
Dans LAN, il doit exister une interface br-lan qui fait un pont entre le réseau Wifi interne et eth1 correspondant aux ports réseaux internes.

Après il faut modifier les règles du pare-feu pour autoriser les sorties sur le réseau universitaire.

#5  - tomazinio a dit :

Merci, je vais essayer comme cela.

Vous remerciant de votre aide,
Cordialement.

#6  - tomazinio a dit :

Bonjour,

Bon, j'ai essayé les manipulations indiquées et cela ne fonctionne pas.

J'ai créé un 1er réseau wifi RTN66U_2.4G (ce n'est pas le réseau universitaire mais le réseau de mon domicile) en mode client et rattaché au WAN.

Ensuite, j'ai créé un 2ème réseau wifi RezoCaro en mode point d'accès et rattaché au LAN.

Puis, je suis allé voir l'interface réseau WAN. Elle était bien paramétrée en client DHCP. Je n'ai rien modifié.

Puis, je suis allé voir l'interface réseau LAN. Je ne vois pas d'interface br-lan. J'ai cela https://framapic.org/1e4Gt64KCZrY/tK8Mh89aoDE4.png à la place.

Le problème viendrait-il de cela ou la carte wifi de mon routeur NEXX WT3020F ne sait pas gérer 2 SSID ?

Ci-joint aussi la page des réseaux wifi https://framapic.org/HxfTU0cIEkKW/OprkSbxmiFqM.png

vous remerciant de votre aide,
Cordialement.

#7  - Nicolas Sulek a dit :

Il faut que vous supprimiez le SSID OpenWrt, c'est celui par défaut, mais vous n'en avez pas l'utilité.

Ensuite, il faudrait trouver pourquoi le routeur n'arrive pas à se connecter au réseau RTN66U_2.4G. Ca pourrait effectivement venir du fait que la carte ne sache pas gérer plusieurs SSID. Il faudrait vous connecter à ce SSID avec un autre ordinateur pour voir les paramètres et les retranscrire dans OpenWrt, en espérant qu'il n'y est pas un filtrage par adresse MAC.

Pour l'interface LAN, ça semble bon, il y a bien un pont entre le réseau Wifi interne et les ports réseaux internes du routeur.

#8  - tomazinio a dit :

Bonjour,

Je n'arrive pas à supprimer le SSID OpenWrt avec l'interfac web LuCI. En ligne de commande, je ne sais pas le faire alors je vais réinstaller.

J'arrive à me connecter au réseau RTN66U_2.4G avec mon ordinateur portable et il n'y a pas de filtrage par adresse MAC.

Comment est-ce que je peux savoir si la carte wifi d'un routeur accepte plusieurs SSID ?

Vous remerciant de votre aide,
Cordialement.

#9  - tomazinio a dit :

Bon, j'ai réinstallé et avancé un peu.

J'avais toujours le SSID OpenWrt. J'ai essayé de l'éditer pour le remplacer par le réseau RTN66U_2.4G. Je n'ai pas réussi. J'ai alors fait un scan des réseaux wifi au lieu de l'ajouter manuellement. J'ai rentré la clé WPA et là ça a fonctionné. Le SSID OpenWrt a été remplacé par le réseau RTN66U_2.4G. Il est bien en mode client et je l'ai rattaché au WAN. Sur l'icone de puissance sans fil, il y avait les 4 barres pleines et 95%.

J'ai ensuite ajouter le 2ème réseau wifi RezoCaro en mode point d'accès et rattaché au LAN.

Puis, je suis allé voir l'interface réseau WAN. Elle était bien paramétrée en client DHCP. Je n'ai rien modifié.

Puis, je suis allé voir l'interface réseau LAN. J'ai cela https://framapic.org/HBtqooOTrIgx/7huAol1PGtQF.png
Je n'ai rien modifié.

J'ai désormais cela dans la page des réseaux wifi https://framapic.org/54eQ1hfPoMgu/h8MiBUSy1FOu.png

Mon ordinateur portable étant connecté en filaire au routeur NEXX WT3020F, j'ai constaté alors un accès à internet sur celle-ci. Mais lorsque je vais consulter un site, je n'y accède pas. C'est probablement le problème du paramétraqe du pare-feu que vous m'indiquiez précédemment et/ou le problème des serveurs DNS que je n'ai pas paramétrés.

En revanche, je ne vois toujours pas le 2ème réseau wifi RezoCaro lorsque je recherche les réseaux sans-fil.

Je pense que je me rapproche du but mais ce n'est pas encore tout à fait ça.

Vous remerciant encore de votre aide,
Cordialement.

#10  - tomazinio a dit :

rectificatif : finalement, je n'ai pas d'accès internet en filaire. Au redémarrage du routeur, plus rien. Donc, pas trop d'avancée alors.

Cordialement.

#11  - Nicolas Sulek a dit :

arf :-/

pourriez-vous me montrer vos fichiers /etc/config/wireless et /etc/config/network (en cachant les mots de passe bien sûr) ?

#12  - tomazinio a dit :

Bonjour,

Voici le fichier wireless
https://framadrop.org/r/4kxDFllagu#RC0sBeGxJjlmheZfq18vtqoU6/NPcwQ3qI7/w9LPoSw=
et le fichier network
https://framadrop.org/r/GZg7aOU3U9#1aISlDxZwMxnh/AmjteJXcbVLMmhnDrLBuAouxRDFhY=
Vous remerciant de votre aide,
Cordialement

#13  - Nicolas Sulek a dit :

Bizarre que ça ne reste pas :-/

Essayez déjà de vérifier que votre routeur a bien accès au réseau universitaire, par exemple, en faisant un ping google.fr en SSH ou en utilisant les diagnostics réseaux de l'interface Web.
Si ça c'est bon, essayez de vous connecter à votre réseau interne WiFI.
Si c'est bon aussi, il ne restera plus qu'à activer le NAT au niveau du pare-feu.

#14  - tomazinio a dit :

Bonjour,

Les fichiers network et wireless vous semblent donc corrects alors ?

Le ping google.fr renvoit bad address en SSH et en utilisant les diagnostics réseaux de l'interface Web.

Vous remerciant de votre aide,
Cordialement.

#15  - Nicolas Sulek a dit :

Bonjour,

désolé également pour le délai de réponse.

Le fichier wifi me semble correct.
Pour le fichier network, c'est un peu plus compliqué. Sur votre modèle de routeur; il n'y aurait pas de eth1 comme interface pour le LAN. eth0 pour le WAN est en fait eth0.2 et eth1 pour le LAN est eth0.1.

Il est possible que ces VLAN compliquent la connection au réseau universitaire. Il faudrait vérifier si déjà vous arrivez bien à vous connecter au réseau universitaire en regardant si vous êtes bien associé dans l'interface Web d'OpenWrt, puis en ssh, en faisant un ifconfig pour voir si vous récupérez bien une adresse IP, car il semblerait que pour le moment, ça ne fonctionne pas.

#16  - tomazinio a dit :

Bonjour,

Ok, merci. Pas de problèmes.

Je ne comprends pas ce que vous voulez dire par : «Il faudrait vérifier si déjà vous arrivez bien à vous connecter au réseau universitaire en regardant si vous êtes bien associé dans l'interface Web d'OpenWrt»

J'avais cela https://framapic.org/54eQ1hfPoMgu/h8MiBUSy1FOu.png. Je ne vois pas d'équipements associés. C'est cela qu'il faut que je vérifie ? que je corrige ? Comment ?

Vous remerciant de votre aide,
Cordialement.

#17  - Nicolas Sulek a dit :

si on en croit la capture, vous n'êtes pas connecté à RTN66U, le signal affiché étant à 0%.
Un iw dev wlan0 link ou iw dev wlan1 link en console devrait confirmer.

#18  - tomazinio a dit :

Bonjour,

Effectivement, pour iw dev wlan0 link, j'ai en réponse «not connected» mais pourquoi ?

Ce n'est ni un problème de mot de passe (je me connecte bien avec mon micro-ordinateur sur RTN66U avec le même mot de passe. j'ai fait un copié/collé), ni de puissance du signal (le routeur NEXX WT3020F est à 1 mètre du routeur RTN66U).

Je me souviens au début lorsque j'ai installé le réseau RTN66U_2.4Gen mode client, il y avait bien du signal > à 90% mais plus rien lorsque j'ai installé le 2ème réseau wifi RezoCaro en mode point d'accès.

Ça me prend bien la tête ce routeur OpenWRT !!! Est-ce que vous voyez une solution et/ou autre chose à faire ?

Vous remerciant de votre aide,
Cordialement.

#19  - Nicolas Sulek a dit :

Malheureusement non, je ne vois rien d'autres à faire si votre carte ne peut être à la fois client d'un réseau et point d'accès d'un autre :-/

#20  - tomazinio a dit :

Bonjour,

Ok, merci. tant pis. C'est donc, à votre avis, un problème de carte wifi du routeur.
Il faudra alors que je change de routeur.
Que faut-il à un routeur comme caractéristiques techniques pour être à la fois client d'un réseau et point d'accès d'un autre ?

Vous remerciant encore de votre aide,
Cordialement

#21  - Nicolas Sulek a dit :

c'est une supposition.
Il faudrait supprimer un des deux réseaux Wifi pour voir si le routeur est bien client ou point d'accès suivant le réseau. Et si ça fonctionne avec un seul réseau Wifi, rajouter le 2ème pour voir ce qui se passe.

Personnellement, je n'ai utilisé que des Tp-Link Archer C7 https://wiki.openwrt.org/toh/tp-link/archer-c5-c7-wdr7500 dont je suis très content.

#22  - tomazinio a dit :

Bonjour,

Ok, merci. C'était ce que j'avais déjà fait. J'ai installé le réseau RTN66U_2.4Gen mode client, il y avait bien du signal > à 90% mais plus rien lorsque j'ai installé le 2ème réseau wifi RezoCaro en mode point d'accès.

Je vais regardé du coté des Tp-Link Archer C7 alors.

J'ai regardé pour le Mini Router GL-AR300M(D). J'ai posé la question au fabricant (clairement je pense) : the wireless card is it multi-SSID ? is it possible to connect a first
wireless network in client mode and a second in access point mode?

Voici sa réponse (pas claire pour moi) : You mean the GL-AR300MD dual wifi version? That one is still in test and not launch yet. Mais je pense que cela ne le fait pas.

En fait, je cherche un mini-routeur pour des questions de prix et portabilité.

Vous remerciant de votre aide,
Cordialement

#23  - Nicolas Sulek a dit :

Effectivement, la réponse pour le Mini Router GL-AR300M(D) n'inspire pas trop confiance :-/

Après, il faut regarder sur le site d'Openwrt https://wiki.openwrt.org/toh/start les différents modèles et voir ce qui sont encore commercialisés

#24  - tomazinio a dit :

Bonjour,

Ok, merci.

Pourtant mon routeur NEXX WT3020F est bien sur le site d'Openwrt mais la carte wifi ne semble pas permettre d'être à la fois client d'un réseau et point d'accès d'un autre.

Je finis par me dire que je cherche quelquechose qui n'existe pas. En définitive, un mini-routeur compatible OpenWRT avec une carte Wifi permettant d'être à la fois client d'un réseau et point d'accès d'un autre.

Auriez-vous une idée où je peux poser la question (en fr) ? 

Vous remerciant encore de votre aide,

Cordialement.

#25  - Nicolas Sulek a dit :

désolé, je ne sais pas trop où vous pourriez chercher, encore plus en français :-/

#26  - tomazinio a dit :

Bonjour,

Ok, merci pour votre aide en tout cas.

Cordialement.

#27  - tomazinio a dit :

À la réflexion et si cela vous demande moins de temps, vous pouvez peut être me communiquer les liens du wiki d'openwrt qui permettent de faire cela. En reproduisant la même chose, je pourrais peut être y arriver.

Vous remerciant encore de votre aide,
Cordialement.

#28  - Nicolas Sulek a dit :

Vous pouvez regarder ce tutoriel qui correspond presque à votre demande : https://wiki.openwrt.org/doc/recipes/routedclient
Tous les modes clients Wifi d'openwrt sont visibles ici : https://wiki.openwrt.org/doc/howto/clientmode

#29  - tomazinio a dit :

Ok, merci. Je vais essayer avec cela.

Vous remerciant de votre aide,
Cordialement.

#30  - Nicolas Sulek a dit :

En fait, il ne faut pas tout suivre à la lettre. Si mes souvenirs sont bons, openwrt est déjà bien configuré pour faire communiquer WAN et LAN, il n'y a donc que la création des deux réseaux Wifi (1 en WAN et l'autre en LAN) à faire sans doute.

#31  - tomazinio a dit :

Merci de ces précisions. J'étais en train de ramer sur les pages du wiki. Je vais plutôt faire comme vous m'indiquez et avec l'interface LuCI. Ce sera plus simple pour moi.

Vous remerciant encore de votre aide,
Cordialement.

#32  - Arnold a dit :

Bonjour,

Votre article tombe à pic et à dire vrai c'est le seul que j'ai trouvé à ce sujet (fbs et fbp via routeur en mode wifi). Encore merci !
J'essaie d'effectuer la même configuration mais avec des routeurs Gl-inet.
J'ai essayer d'adapter au mieux mais ça ne marche pour l'instant pas.
Sans doute quelques réponses pourraient m'aider à y voir plus clair sachant que je suis un peu noob sur les vlan et je m'excuse si mes questions ne veulent rien dire.

D'après ce que j'ai compris quand on fait que du filaire avec un routeur entre le fbs et le fbp, on tag le proc, le port wan pour le fbs et un port lan auquel sera connecté le fbp.
1. A quoi correspondent ces 3 ports '0t 1t 6t' ? Pourquoi ne pas lister l'ensemble des ports lan aussi ? Puisqu'on passe par le wifi qui pour moi n'a pas de port je ne vois pas trop quel port lan tagger ?
2. La plupart des blog parle du mode fbs en mode bridge. Cette solution marche aussi avec le mode routeur de la freebox ?
3. L'interface "fbx" est en proto "none". Comment le client wifi va recevoir une ip ? et comment l fbs va recevoir une ip ?
4. pourquoi branché le fbp au wan du 2 eme routeur ? Ca marcherait aussi sur le lan ?
5. j'ai essayé de me connecté via mon pc au wifi du routeur 1 vlanisé 100 mais impossible. Est-ce normal ?
6. Serait t'il possible dans l'absolu de donner accès au flux web (non vlanisé ?) au fbp en plus du flux vlanisé 100 afin de faire fonctionner les autres services ?

Encore merci pour cet article.

Cordialement.

#33  - tomazinio a dit :

Bonjour,

Je n'ai malheureusement pas les réponses à vos questions mais je vois que vous utilisez des routeurs GL-inet. Je m'intéresse à leurs mini-routeurs pour résoudre mon problème cité plus haut.

Avez-vous un de leurs mini-routeurs ? Si oui, quel modèle ? En êtes vous content ?

L'interface web est-elle en francais (je ne suis pas très bon en anglais) ? Vous avez laissé le firmware d'origine ou flashé avec OpenWRT ?

Vous remerciant de vos réponses,
Cordialement.

#34  - Arnold a dit :

On m'a prété le gl-ar150 et je viens d'acheter le GL-MT300A.
Depuis que je joue avec, le GL-MT300A me semble plus robuste et la gestion des vlan me semble plus clair.
Sur l'ar150 la superposition des connexions wifi me semble pas très stable.
Rien à dire avec le GL-MT300A c'est vraiment bien.
L'interface n'est pas en francais par défaut mais de toute facon je clique sur advanced settings et j'arrive dans l'interface openwrt en francais. A la réception du GL-MT300A openwrt etait déjà présent.

#35  - tomazinio a dit :

Merci bien pour ces infos.
Alors, je vais regarder de plus prêt le GL-MT300A.
Cordialement

#36  - Nicolas Sulek a dit :

Bonjour,

1- je comprends tout à fait votre question, car ce n'est vraiment pas limpide. Le rôle des ports 0, 1 et 6 est spécifique au TP-Link Archer C7, il est fort possible que ce ne soit pas la même chose sur les Gl-inet. Pour l'Archer, les ports 1 et 6 correspondent au WAN et le port 0 correspond au LAN. Il n'est pas nécessaire de lister tous les ports du switch, car le VLAN de la Freebox ne va être affecté que sur le port WAN et le port LAN pour pouvoir le transporter sur le WiFI. En gros, eth0 correspond à tout ce qui est extérieur à notre réseau (WAN) et eth1 correspond à tout ce qui est interne à notre réseau.
2- tout à fait, je suis en mode routeur (ma Freebox a une adresse IP en 192.168...) et ça fonctionne très bien.
3- l'interface fbx ne reçoit pas d'adresse IP, elle sert juste de transport jusq'au boitier TV de la Freebox qui lui va en demander en DHCP.
4- oui, ça fonctionnerait également, le tout est d'affecter le bon VLAN au bon port. J'ai mis sur le WAN du 2ème routeur pour que ce soit plus clair.
5- je pense que c'est normal; car c'est un VLAN propre à Free.
6- normalement, tout doit fonctionner avec le VLAN 100, pas besoin de rajouter un autre VLAN. Le Freebox Player est directement connecté au réseau de Free, il ne passe pas du tout par notre réseau interne.

#37  - Arnold a dit :

Merci énormément pour toutes ces réponses ! Je m'y remets pour que ca fonctionne ;)

#38  - Arnold a dit :

Bonsoir Nicolas,

Je n'y arrive toujours pas .

Au niveau du routeur 1 :
En fait la différence chez moi c'est que je n'ai pas d'eth0 et eth1 mais plutot eth0.2 qui est le wan et eth0.1 qui est le lan : le vlan 1 est attaché aux ports 1 2 3 4 5 6t et le vlan 2 aux ports 0 6t
il existe un bridge br-lan qui relie eth0.1 au wifi
Le device est switch0
J'ai donc ajouté le vlan 100 sur les ports 0t 1t 6t

Le problème quand je créé l'interface fbx, c'est que je ne sais pas quoi mettre dans le ifname : juste eth0.100 ?

Ensuite j'associe une nouvelle connexion wifi en mode ap sur le réseau fbx.

Au niveau du routeur 2 :
Cette fois-ci je ne connais meme pas le nom du device. Il semble qu'eth1 (lan) soit un switch et eth0 est le wan.
J'ajoute donc la configuration suivante :

config 'switch' 'eth1'
option 'enable' '1'
option 'enable_vlan' '1'
option 'reset' '1'

config switch_vlan
option device 'eth1'
option vlan '100'
option vid '100'
option ports '0t 1t'

config 'interface' 'fbx'
option 'proto' 'none'
option 'send_rs' '0'
option 'stp' '1'
option 'type' 'bridge'
option 'ifname' 'eth1.100'

et je créé une connexion wifi cliente sur le reseau fbx associé au bridge fbx.

Quand je branche le freebox player au port lan du routeur 2 rien ne marche. Le souci c'est que je n'ai aucun moyen de savoir d'où vient le problème et je ne sais pas comment analyser les trames ou faire des tests en telnet ou autre. Bref, je suis un peu bloqué. Verrais-tu par hazard une erreur ou une manière d'aller plus loin ?

Encore désolé pour toutes ces questions !

Merci

#39  - Nicolas Sulek a dit :

Bonjour,

désolé pour le délai de réponse.

eth0.100 me semble effectivement correct, mais il faut aussi eth1.100 pour faire le lien entre WAN et LAN.
Pour tester déjà que ça fonctionne, tu peux associer un port du switch au vlan 100 (par exemple, rajouter 2t) et ton boitier freebox player pour voir si les connexion passent, avant de t'attaquer à la partie Wifi.

Ensuite pour débugguer, j'utilisais tcpdump directement sur le routeur sous OpenWrt pour écouter les communications passant sur eth0.100 et eth1.100. Tu devrais voir des demandes DHPC émises par le Freebox Player.

Les commentaires sont fermés.

Fil RSS des commentaires de cet article